你现在的位置:首页 > PHP网站建设知识库 > ZenCart > 正文

运行zecart的服务器的配置

zencartV1.5.0 
服务器的最低配置要求: 
PHP 5.2.14或更高版本,或PHP的5.3.5或更高。具体来说,您应使用最新的PCI兼容的版本作为每个PCI的标准。 
Apache 2.x或更新(特别是最新的PCI兼容的版本) 
MySQL 5或更高(再次使用PCI兼容的版本)(将工作与MySQL 4.1.3) 
注:许多https和支付模块需要安装/编译PHP和OpenSSL。 
注:接受的付款方式可能需要对https的支持。建议帐户创建和结帐时使用SSL,是符合PA-DSS要求。 

PHP版本 
zencart v1.2.x通过v1.3.6兼容与PHP 4.3.2 - 4.4.x.他们和PHP 5是不兼容的。 
zencart v1.3.7-v1.3.8a是通过PHP 5.2.x与PHP 4.3.2兼容, 但与PHP 5.3不兼容。 
zencart v1.3.9系列是兼容PHP 5.3.2和PHP的5.3.xx. 
zencartv1.5.x是通过PHP 5.3.xx兼容PHP 5.2.14 
注:PHP 4.x中不再支持PHP的原版,在很大程度上被视为不安全的PCI标准。不建议在任何上线服务器上使用PHP 4.x。 
注册全局可能开启或关闭,“关”是出于安全原因。 
safe_mode设置关闭,也是出于安全原因 
MySQL版本 
MySQL的5不正式支持zencart v1.3.7和更低的zencart。 
然而,店主运行v1.3.6和更新似乎是相当成功的。 v1.2.x和v1.3.x许多插件不能正确写入到MySQL 5标准,如果你选择使用它们,可能需要改变。 
使用最新版本的zencart的建议是最大的兼容性。 
zencartv1.3.9和v1.5.x兼容与MySQL 4和5 
zencart2.0版已经写的MySQL 5.1 +的插件兼容性可能会有所不同。 

zencart 
zencart  V2.0(目前正在开发中),将有不同的最低要求: 
PHP 5.3.5最低,与PHP 5.4兼容 
SSL支持编译入PHP 
MySQL5。 (可能与MySQL 4.x的兼容,但需要注意的是,MySQL的原版是结束旧版本的支持。) 
SSL建议,确实需要PA-DSS合规性 
注:使用HTTPS(即:SSL)强烈建议您对您的客户收集的数据进行保护。一些支付模块需要SSL才能正常工作,没有SSL往往会失去商业银行和PCI法规的服务条款。
寄存器的全局应该关闭 。
PHP的安全模式应该始终是关闭的。