你现在的位置:首页 > opencart 正文

如何更新opencart的jquery库

opencart是一个非常优秀的php开源B2C电子商务系统,其中使用了大量的jquery的效果。PHP网站建设工作室在开发基于OpenCart的网站时,发现有时我们引入一个jquery的特效插件后,不能正常工作,后来才发现原来是当前版本的OpenCart中的jquery库不是最新的,所以很有必要将opencart中的jquery库更新为最新版本。

\

  1. 先到jquery的官网http://jquery.com/download/,下载一个最版本的jquery的文件,文件名应该是.js的,比如说我们下载到一个jquery-1.10.2.min.js这个文件。
  2. 打开catalog/view/theme/YOURTHEME/template/common/header.tp这个文件
  3. 找到<script type="text/javascript" src="catalog/view/javascript/jquery/jquery-1.6.1.min.js"></script>,找到当前系统所使用的jquery的版本号及文件所在目录,注意,jquery-1.6.1.min.js会随着opencart版本的不同而变化。
  4. 我们打开opencart的\catalog\view\javascript\jquery\这个目录,把之前下载好的jqjquery-1.10.2.min.js文件放在这里。
  5. 最后,我们再编辑catalog/view/theme/YOURTHEME/template/common/header.tp这个文件,找到<script type="text/javascript" src="catalog/view/javascript/jquery/jquery-1.6.1.min.js"></script>,把jquery-1.6.1.min.js替换成jquery-1.10.2.min.js。
  6. 大功告成。