你现在的位置:首页 > PHP网站建设知识库 > magento > 正文

Magento的系统需求

下面是Magento的运行环境最低需求配置:

Linux, Windows, 或其他 UNIX兼容操作系统 (不推荐在正式商用环境中使用windows)
Apache Web Server (1.x or 2.x),Nginx,litespeed
PHP 5.2.0 以上, 并且包含下列扩展(Extensions/Addons):
PDO/MySQL
MySQLi
mcrypt
mhash
simplexml
DOM
curl
gd
soap
MySQL 4.1.20 或更新版本
Sendmail兼容的 Mail Transfer Agent (MTA)
如果没有MTA,Magento将直接连接一个 SMTP server
我们还建议使用APC作为一个缓存,将会使Magento获得性能方面的改进。你可以在PECL中找到它:http://pecl.php.net/package/APC。其他缓存系统暂时不支持。

如果您不确定您的服务器托管公司是否支持这些功能,可以下载系统需求测试文件,放在服务器上测试。 具体方法如下:

1.首先先下载系统需求测试文件(magento-check.zip).
2.解压缩magento-check.zip为magento-check.php,并上传到你主机的根目录下.
3.在浏览器上运行该php文件.比如:www.domain.com/magento-check.php
 

如果你的服务器支持上面提到的一些条件, 那么你就可以下载并安装Magento了